The Compound module
• Use Compound for the administration of a private compound database,
i.e. enter, edit, delete pure substance data in a database.
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The Compound module

• Click on Compound in the
main FactSage window to
activate this module.
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Create a private Compound database

Before you can start entering compound data in a private database you
must first create the database file with the basic information.
A directory must be chosen and a file name be given, a nick name must
be defined and a short database description may be entered.
At the end of this procedure the Compound module will give a status of
the new database showing
–

its location:

path\name

–

the number of compounds it contains:

0 compound(s) initially;

–

the FactSage version it goes with:

5.0

–

and its access permission:

read/write.
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Create a private Compound database, I
To create a read and write (r/w) database:
1. Click on «New
Database…» from
the «File» Menu

2. Choose a filename
and select a directory
for your new database
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Create a private Compound database, II
The program selects
automatically a four character
nickname and adds the suffix
-BASE to complete the name
of your private database.
You can edit the nickname.

You can enter a short description
of your private database (with a
maximum of 79 characters).
The status bar provides information on the database:
• its location:
C:\FACT-51\DATABASE\EXAMPLEBASE.CDB;
• the number of compounds it contains:
0 compound(s) (for now);
• its version:
5.0;
• and its access permission:
read/write.
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Add a compound to the database

The following 20 slides (sections 4 to 9) show how to enter the
data for a new compound with three phases (solid, liquid, gas)
into a private database.
MgCl2 is taken as an example. The data for this compound are
summarized in slide 4.3.
4.3 All entries are made using the values in
this figure.
The two different variants of entering data are demonstrated:
1) H298, S298 and Cp with transition data for the high temperature
phase (using data for solid and liquid MgCl2)
2) H298, S298 and Cp for the high temperature phase itself (using
data for the gas).
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Add a compound to the database, I
To enter a new compound,
for example MgCl2, in the
EXAMBASE:
1. Select EXAMBASE database
2. Type the chemical formula
of the compound: MgCl2,
in the Formula input box
3. Select the function «Add
MgCl2 to EXAMBASE»
from the Edit Menu.
4. Select input units
for the compound.

5. Press «OK»
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Add a compound to the database, II
Your database is now ready for a new entry or for a modification of a compound’s data.
6. If you want, you can enter:
•the compound name;
•reference number(s);
•and comments.
7. Right click on MgCl2
to access the following
pop-up menu.

The Real Stoichiometry input box appears if you have
checked «Real stoichiometry» in the menu View. This
feature is for advanced users only and applies to every
phase of the compound (it does not apply to elements).
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Add a compound to the database, III
CP(G) = 95 J/mol·K

G1

SoG,298.15 = 194.1 J/mol·K

-481145

→ MgCl2

Mg(s) + Cl2(g)

(298 K)

(298 K)

(T)

H (J/mol)

Data for MgCl2 are
taken from this graph
and entered into a
private database.

ΔHvap.= 156000 J/mol

CP(L) = 92.5 J/mol·K

L1
o
SL,298.15
= 106.2 J/mol·K

ΔHfusion= 43000 J/mol
-633607

S1
-668000

CP(S) = 79.1 + 0.594 × 10-2 T - 8.62 × 105 T-2 J/mol·K

SoS,298.15 = 79.0 J/mol·K

298.15

987

Temperature (K)
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Add a compound to the database: H298 and S298 for 1st phase, IV
1. In the pop-up menu, point the arrow to «Add phase…»
and select «Solid» from the sub menu with a left click.
2. Enter the values for the enthalpy
of formation (ΔH°s,298.15) and
entropy (S°s,298.15). Compound
only takes these values when
entering data for the first phase.
The Extended properties input
box appears if you have
checked «Extended properties»
in the menu View.
This feature
applies to a
phase
exclusively.
3. Left click on Cp 6000 to
open the input box for Cp.

Values of ΔH°s,298.15 and S°s,298.15 were
obtained from the graph (see previous slide)
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Add a compound to the database: extended properties, V
Thermal expansion expression: a + bT +
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Compressibility expression:
d
a + bT + cT 2 + 3 ⎡⎣bar −1 ⎤⎦
T

Bulk modulus derivative expression: a + bT ln T
Tc

p

Magnetic contribution expression to the Gibbs free energy Gmag:
T
Gmag = RT ln ( β + 1) g (τ ) where τ =
and ß is the magnetic moment.
Tc
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⎥
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where D =

518 11692 −1
+
( p − 1) , p is a phase (structure) dependent factor.
1125 15975
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Add a compound to the database: Cp values for the 1st phase, VI
1. Left click on Cp 6000 to
open the input box «Cp
expression for S1».
You can enter expressions for
Cp and list those of H, S or G.

2. Enter the CP range from 298.15 K to 987 K
and the CP expression for MgCl2 S1 (see slide 4.3)
4.3
CP(S)= 79.1 + 5.94×10-3 T - 8.62×105 T-2 J/mol·K
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Show data as H, S and G functions

Compound permits the conversion of H298, S298 and Cp input
data into enthalpy, entropy and Gibbs energy functions.
The coefficients of these H, S and G functions can be viewed
directly.
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Show data as H, S and G functions
Compound calculates automatically
the expressions of H, S and G from
your entry of the Cp expression.

The data colored in gray indicates that
you can not edit these expressions.
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Edit the Gibbs Energy function

The following slide shows how to edit the data of a compound
phase when using the Gibbs energy coefficients instead of H, S
and Cp data.
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Edit the Gibbs Energy function
Compound gives you the possibility to edit the Gibbs energy
function by pressing the Edit button to open a G Input form.

The data colored in black indicates
that you can edit these expressions.
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Entering phase transition data: the liquid phase

•

The next three slides illustrate how to enter a new phase
(here the liquid) if the data for the phase transition between
the previous phase (here the solid) and the new phase, i.e.
ΔH and Ttrans, as well as the Cp data of the new phase are
available.
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Entering phase transition data: the liquid phase, I
1. Right click on «

» to open a pop-up menu.

2. Point the arrow to «Add
phase…» and select
«Liquid» from the sub
menu with a click.

3. Compound proposes two ways
to enter the data:
•either you enter the enthalpy
of formation (ΔH°L, 298.15) and
entropy (S°L, 298.15) and the
entry is flagged by the icon
•or you enter the enthalpy
and temperature of
transformation and the entry
is flagged by the icon
Compound 7.1
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Entering phase transition data: the liquid phase, II
3.(continued)
Entering the enthalpy
and temperature of
transformation.

4. Click on Cp 6000 to open the
box «Cp expression for L1»

The Extended properties input box appears if you
have checked «Extended properties» in the menu
View. This feature applies to a phase exclusively.
Compound 7.2
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Entering phase transition data: Cp coefficients of the liquid phase, III
Compound calculates automatically the values of ΔH°L, 298.15 and
S°L, 298.15 (these values are the same as those in slide 4.3).
4.3

5. Enter the CP range from 298.15 K to 1691 K and the CP expression
for MgCl2 liquid (slide #6): CP(L)= 92.5J/mol·K
Compound 7.3
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Entering a new phase with H298, S298 and Cp: the gaseous phase

The following three slides show how an additional phase (here
the gas) is entered for which H298, S298 and Cp are known.
The entry of extended data for the non-ideal behaviour of the gas
according to the Tsonopoulos method is also shown.
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Entering a new phase with H298, S298 and Cp: the gaseous phase, I

1. Right click on «
»
to open a pop-up menu.

2. Point the arrow to «Add phase…» and select
«Gas» from the sub menu with a click.
Compound 8.1
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Entering a new phase with H298, S298 and Cp: the gaseous phase, II

3. Enter the values for the
enthalpy of formation
(ΔH°G,298.15) and the
entropy (S°G,298.15).
(See slide 4.3)
4.3

4. Click on Cp 6000 to open the
box «Cp expression for L1»

The Extended properties input box appears if you
have checked «Extended properties» in the menu
View. This feature applies to a phase exclusively.
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Entering a new phase with H298, S298 and Cp: extended properties for the gas, III
The truncated virial equation of state is employed to treat real gases:

PV
BP
= 1+
RT
RT
B is estimated for pure gases and mixtures by the Tsonopoulos*
method from Pc, Tc, and Ω (omega, the acentric factor) for the pure
gases. Gases are treated as non-polar. For ideal gases, the value
of B is zero.

Tc

Pc
Ω

*

Vc
μ

«An Empirical Correlation of Second Virial Coefficients» by C. Tsonopoulos,
AIChE Journal, vol. 20, No 2, pp. 263-271, 1974.
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Finishing and saving the entry

The next slide shows how the last data item for MgCl2, the Cp
coefficient of the gas phase, is entered
and
the complete dataset is saved in the private database.
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Finishing and saving the entry, I
5. Enter the CP range from
298.15 K to 6000 K and
the CP expression for
MgCl2 gas (slide 4.3)
4.3 :
CP(G)= 95 J/mol·K

6. Press on the Save button ( ) to complete your entry for this
compound (You can also select «Save MgCl2 to EXAMBASE»
from the menu Edit). Now your database contains 1 compound.
The fading of the compound icon (from
to
)
indicates that your data are saved.
Compound 9.1
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Viewing data and finding species

If you wish to inspect data for a compound in the format used by
the View Data module you may do so from within the
Compound module.
You may also inspect lists of chemical systems as generated by
the View Data module from within the Compound module.
The following three view graphs show how to perform these
tasks.
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Viewing data and finding species, I
1. Click on «ViewData» in the menu bar to open the
ViewData application at the compound (MgCl2)
and the database (EXAMBASE) you have
selected (or the last you just worked in).
2. Click on the Cp(T) and
Phases tabs to see the
data you have just
entered or the values
calculated by Compound
from your data entry.
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Viewing data and finding species, II
1. To look at the data of a compound found in a database, for example
MgSO4 in FACTBASE: enter MgSO4 in the Formula input box.

Move the pointer over the
reference text box to view
the detailed bibliography

“Thermochemical Properties of Inorganic Substances”,
I. Barin, O. Knacke, and O. Kubaschewski,
Springer-Verlag, Berlin, 1977.
(for non-aqueous species)
appended to:
“Handbook of Thermochemical Data for Compounds and Aqueous Species”,
H.E. Barner and R.V. Scheuerman,
Wiley-Interscience, New York, 1978.
(for aqueous species)

2. Expand the tree structure for FACTBASE and search through the MgSO4
branches to list its data. Note that data for MgCl2 is also shown.
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Viewing data and finding species, III
1. Select «List of
products» in
the View menu.

2. Enter a chemical formula of a compound (
)
or the elements (
) of interest in the Formula
input box. For example O, S and Mg.

3. Expand the tree structure to see the list of
compounds containing O, S and/or Mg.
Compound 10.3
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Transferring data between databases

Data for single compounds can easily be transferred between
databases.
This is particularly useful if you want to investigate how data
changes for a compound in a read only database affect results in
calculations. Simply generate your own private read and write
database and copy the desired compound(s) from the read only
database over to your private database.
There are two ways how to do that which will are described in the
following to view graphs.
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Transferring data between databases, I
1. Select the compound of interest in its database.
For example, click on MgSO4 in FACTBASE.

2. Select «Copy» from
the Edit menu.

3. Select the destination database.
Here, EXAMBASE.

4. Select «Paste MgSO4» from the Edit menu.
Compound 11.1
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Transferring data between databases, II
Note that the MgSO4 data retrieved from the
read only (r) FACTBASE database are shown
in gray color and you can not edit them.

Simply drag-and-drop MgSO4
from FACTBASE to EXAMBASE.

Note that the MgSO4 data retrieved from the
read and write (r/w) EXAMBASE database are
shown in black color and you can edit them.
Compound 11.2
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Editing a read and write (r/w) database

Data in a read and write database may be added, removed or
modified.
In the example the Cp range for the solid (S1) phase of MgSO4 in
the r/w EXAMBASE database is edited.
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Editing a read and write (r/w) database.
You can expand and reduce the
extent of the tree structure of the
databases by left clicking on the
box at the right of an icon.
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The Erase, Remove and Clear commands

The Erase, Remove and Clear commands permit
•

to erase (delete) single compounds from a particular
database,

•

to remove single compounds from an edit list
and

•

to clear complete edit lists.

NOTE:

The latter two commands do NOT interfer with the
contents of databases. They are therefore
applicable with all types of databases.
The Erase command only works for read/write
databases.
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The Erase, Remove and Clear commands, I
1. Select the compound you want to delete
(say, CO2) from the r/w database.
2. Go to the Edit menu and select
Erase CO2 from EXAMBASE.

3. Confirm your intention
to erase data
Now the database EXAMBASE
contains only 2 (= 3 - 1) compounds.
Compound 13.1
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The Erase, Remove and Clear commands, II
1. Select the compound you want to remove
(say, CO2) from the tree view list.
2. Go to the Edit menu and select
Remove CO2 from list.

The compound CO2 is not
shown in the tree view but
the database EXAMBASE
still contains 3 compounds.
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The Erase, Remove and Clear commands, III
To remove all the compounds from all the lists (you are not removing the compounds
from the databases) in the treeview (i.e. to clear the treeview):
Go to the Edit menu and select «Clear list of compounds».You
can also press the button «Clear list of compounds» in the toolbar.

The compounds are not
shown in the tree view but
the database EXAMBASE
still contains 3 compounds.
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www.factsage.com

The «Mixer» feature

The «Mixer » feature permits the generation of new compound
data using «simple algebra» on the data of already stored
compounds.
The first example shows how the known data for Na2O and Al2O3
are used in a Neumann-Kopp type sum to generate data for the
unknown compound NaAlO4. The scale down command is used
to come to the desired formula.
Alternatively, the use of the scale up command is shown for the
formula Na3Al3O6.
The second example shows how the known data for Li3N, Li and
Na are used to generate data for the unknown compound Na3N
using Li3N + 3Na - 3Li = Na3N.

Compound 14.0

www.factsage.com

The «Mixer» feature: Example 1, I
The «Mixer» option enables you to create and store compound data on a new
(possibly hypothetical) species by mixing data of existing species. For example,
new data on NaAlO2 via the reaction: ½ Na2O(s1) + ½ Al2O3(s1)→ NaAlO2(s1).
1. Open the database containing the data on Na2O
and Al2O3 and expand the treeview to list phases.

Compound 14.1

2. Click on View > Mixer…
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The «Mixer» feature: Example 1, II
3. Drag and drop the phases to the Compound
Mixer window or use the Add Phase button.

Remove the selected phase
Remove all phases
Add or substract the selected phase

Paste the new compound to a read and write database.

This stores the new compound Al2Na2O4 in the database. To store NaAlO2
you need to use the «Scale Down» command in the Tools menu.

Compound 14.2
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The «Mixer» feature: Example 1, III
To scale down a compound:
1. Save your compound in a r/w
database:
A. Select a r/w database.
B. Paste your compound.
2. Go to the Tools menu and
select «Scale Down».

Now you have the scaled down compound AlNaO2 in your r/w database.
Compound 14.3
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The «Mixer» feature: Example 1, IV
On the other hand, if you want the thermodynamic properties of
Na3Al3O6, which is 3 times AlNaO2, use the Scale Up command.
1. Select the compound you want to scale up
2. Go to the Tools menu and select Scale Up…
3. Enter the scale factor in the
Scaling up compound
dialog box and press «OK».

Now you have the compound
Al3Na3O6 in your r/w database

Compound 14.4
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The «Mixer» feature: Example 2
This example shows how to create new data on Li3N via the synthesis of:
Li3N + 3Na - 3Li.
1. Drag and drop the Li3N, Na and Li phases to Compound Mixer.
2. Click on the Add Phase button to add 3 Na and 3 Li.

3. Press the Add and Substract
button to substract 3 Li from
the reactants. This create
Na3N as product.

Compound 14.5
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Using know data as template

In order to enter data for a new compound you may use the data
of an already stored compound as a template.
The following two view graphs give an example how to use the
known data for MgCl2 in order to generate new data for CaCl2.
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Using know data as template: «Copy data to new Compound» option, I
Suppose you do not want to enter the data of a new compound from scratch and that
you already have the data of a similar compound in your r/w database. You can use the
latter compound’s data as a template for the new one by using the Copy data to new
Compound option in the Tools menu. For example, you have entered data on MgCl2 in
EXAMBASE previously and you want to enter data for CaCl2 that is a similar compound:

1. Select MgCl2 in EXAMBASE.

2. In the Tools menu, select
Copy data to new Compound

Compound 15.1
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Using know data as template, II
3. In the dialog box, enter the new
compound CaCl2 and press «OK».

4. You now have the
CaCl2 template.

Compound 15.2
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Changing Units of Energy or Pressure

Compound permits the change of the units of energy and
pressure both for input and output of the data of a compound.
NOTE:

Changing the energy units will affect H, S and Cp as
well as H, S and G functions.
Changing the pressure units will ONLY influence the
value of S298 of gas species, the first coefficient of the S
function, and the second coefficient of the G function.
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Changing Units of Energy or Pressure
Select the new unit from the cascade menu Units.

Changing Pressure units
from atmosphere to bar.

Changing Energy units
from Joules to calories.
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